Confirmit System Requirements

Document technical information

Format pdf
Size 778.9 kB
First found May 22, 2018

Document content analysis

Category Also themed
Language
English
Type
not defined
Concepts
no text concepts found

Persons

Organizations

Places

Transcript

CONFIRMIT HORIZONS v20 USER SYSTEM REQUIREMENTS
TABLE OF CONTENTS
1
ABOUT THIS DOCUMENT.................................................................................... 2
1.1 REQUIREMENTS FOR ON-PREMISE SERVER INSTALLATIONS .................................................. 2
1.2 RECOMMENDED VS. MINIMUM REQUIREMENTS ............................................................ 2
1.3 REMOVAL OF SUPPORT FOR INTERNET EXPLORER 8, 9 AND 10 ............................................... 2
2
CONFIRMIT HORIZONS MODULES .......................................................................... 2
2.1 CONFIRMIT AUTHORING .................................................................................. 3
2.2 CONFIRMIT EXPRESS ...................................................................................... 5
2.3 CONFIRMIT REPORTAL .................................................................................... 5
2.4 CONFIRMIT SMARTHUB ................................................................................... 7
2.5 CONFIRMIT DISCOVERY ANALYTICS ........................................................................ 8
2.6 CONFIRMIT INSTANT ANALYTICS ........................................................................... 8
2.7 CONFIRMIT ACTIVE DASHBOARDS ......................................................................... 8
2.8 CONFIRMIT ACTION MANAGEMENT ....................................................................... 9
2.9 HIERARCHY MANAGEMENT ............................................................................... 9
2.10 CONFIRMIT SURVEY ENGINE (RESPONDENTS) ............................................................... 9
2.11 CONFIRMIT TRANSLATOR ............................................................................... 10
2.12 CONFIRMIT XML WEB SERVICES ........................................................................ 10
2.13 CONFIRMIT CAPI ....................................................................................... 10
2.13.1 CAPI for Windows ............................................................................................................. 11
2.13.2 CAPI for Android ............................................................................................................... 11
2.13.3 CAPI for iOS ...................................................................................................................... 11
2.14 CONFIRMIT KIOSK ...................................................................................... 12
2.15 CONFIRMIT CATI ....................................................................................... 12
2.16 CONFIRMIT DEBUG STATION ............................................................................ 14
2.17 CONFIRMIT DATA CENTRAL ............................................................................. 15
2.18 CONFIRMIT TCI ........................................................................................ 16
2.19 CONFIRMIT LOCAL DIALER WEB SERVICE ................................................................. 16
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 1 of 16
1 About this Document
This document provides a complete list of the Operating system and setup requirements for Confirmit Horizons users, to
enable users to run the various Confirmit applications and modules. These requirements apply whether the user is
working with an On-Premise or an SaaS system.
Please report any errors in this document to [email protected]
1.1
Requirements for On-Premise Server Installations
System requirements for On-Premise server installations are contained in the Confirmit Server Manual, which is updated
for each new version of the software.
1.2
Recommended vs. Minimum Requirements
In some situations a minimum set of requirements can provide limited functionality. If this is the case, an additional set of
recommended requirements will provide full functionality for the relevant Confirmit module. Users finding that they lack
functionality listed in the Confirmit Horizons User Manual or the Confirmit Reportal Manual should verify that their system
is compliant with the recommended requirements rather than the minimum.
1.3
Removal of Support for Internet Explorer 8, 9 and 10
In Confirmit Horizons Version 20 we no longer offer support for Internet Explorer 8, 9 and 10 for all Confirmit software
accessed by designated users and business users, including Confirmit Authoring and Confirmit Reportal (support for
these older browsers for respondents will continue unchanged). Previously Internet Explorer 10 was supported for
Confirmit SmartHub™, Active Dashboards, Action Management, Hierarchy Management and Discovery Analytics, but
from Version 20 the only supported version of Internet Explorer will be Internet Explorer 11. This change to only support
Internet Explorer 11 is the result of Microsoft’s withdrawal of support for older versions which happened on 12 January
2016 (Click here for more details).
2 Confirmit Horizons Modules
Confirmit Horizons is an extensive software suite that provides user interfaces for end users accessing different
application modules. The list of modules includes:

Confirmit Authoring (Standard and Professional Users)

Confirmit Express

Confirmit Reportal (Designers, Analysts and Viewers)

Confirmit SmartHub

Confirmit Instant Analytics

Active Dashboards

Action Management

Hierarchy Management

Confirmit Survey engine (Respondents)

Confirmit Translator

Confirmit XML Web Services

Confirmit CAPI

Confirmit Kiosk
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 2 of 16

Confirmit CATI

Confirmit Debug Station

Confirmit Data Central
The requirements for using each of these application modules are covered individually in this document.
Confirmit Horizons is designed for use with a minimum screen resolution of 1024 x 768 at 100% browser zoom with the
quick-launch bar collapsed. If your system is set to a lower resolution or a different zoom level, this may prevent
Confirmit Horizons being used. If a Mac is to be used, it must have the right-click functionality available.
2.1
Confirmit Authoring
The Confirmit Authoring module is used for creating and managing surveys in an intuitive web interface. For a full list of
requirements for using Confirmit Authoring, consult the table below.
Confirmit Authoring requirements (Standard and Professional users)
Element
Minimum
Recommended
Operating
system
Windows Vista SP2
OS X*
Microsoft Windows 7, Windows 8 Desktop or
Windows 10.
Web browser
Internet Explorer 11 (Windows only), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases)*
Internet Explorer 11, Firefox (latest) or
Chrome (latest).
Web browsing
enhancement
(Internet
Explorer only)
Microsoft XML parser 3.0 SP3
Microsoft XML parser 6.0
Office
components
Microsoft Office 2003 formats capable office
suite for opening exports:
Microsoft Office 2007, Microsoft Office 2010
or Microsoft Office 2013.
 Microsoft Excel 2003 format capable
spreadsheet editor required for viewing
Rapid Results exports
 Microsoft Word 2003 format capable word
processor required for viewing new
Questionnaire Word Export introduced in
Confirmit 11.
* ”Panelist Editor” and “Compare Survey version” are not supported in Chrome and Firefox. Refer to the Confirmit
Authoring User Guide for details. Chrome on a Mac does not support Silverlight.
The Edge browser is not supported for Survey Authoring or Panel Management, however users will be allowed to log on
via Edge.
Browser capability requirements
Element
Cookies
Description
Client cookies and session cookies must be allowed from the Confirmit server. If the client browser
does not accept cookies, Authoring users will be unable to log on to the system.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 3 of 16
We recommend that users add Confirmit to “Trusted sites” in their browser’s security settings, and that the adjustments
to the security settings mentioned below should be done for trusted sites only:
Browser security settings (Internet Explorer only)
Element
Setting
Purpose / Effect
Binary and Script Behaviors
Enable
Some pages require this setting.
Download Signed ActiveX controls
Enable/
Prompt
If using the VSFlexGrid Pro ActiveX component for editing answer
lists, ActiveX needs to be enabled. If using the DHTML or
Silverlight component for editing answerlists, ActiveX is not
required.
Run ActiveX controls and plugins
Enable
See above.
Script ActiveX controls marked as
safe for scripting
Enable
See above.
Font download
Prompt
Preview of a survey using a font that is not already installed will
not work.
Display mixed content
Prompt/
Some surveys/survey layouts previewed in HTTPS might use
image sources from a HTTP site and vice versa.
Enable
Drag and drop or copy and paste
files
Enable
Users will not be able to drag images into WYSIWYG fields in
Confirmit Horizons when set to Disable or Prompt.
Submit nonencrypted form data
Enable
Will not be able to submit form data in Confirmit Horizons if this is
set to Disable.
Userdata persistence
Enable
Confirmit Horizons stores a lot of information, such as size and
positioning of objects, in userdata.
Active scripting
Enable
Confirmit Horizons uses scripting in most parts of the application.
Allow paste operations via script
Enable
Users will not be able to paste into the WYSIWYG fields of
Confirmit Horizons if this setting is disabled.
Required to allow launching of CATI monitoring from the
interviewer list activity view.
If using IE11, setting must be enabled to display toolbox icons.
Note that IE must be restarted for setting change to take effect.
Automatic prompting for file
downloads
Use software rendering instead of
GPU rendering.
Enable
Enable
Requirements for Answerlists, Survey Data Template Editor and Online Coding
Element
Microsoft
Silverlight
Minimum
Microsoft Silverlight 5.0
Recommended
(Same as minimum)
http://www.microsoft.com/silverlight/resources/install.aspx
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 4 of 16
2.2
Confirmit Express
The Confirmit Express user interface is designed for people with little or no experience from similar applications, and
enables users to easily leverage the Confirmit Horizons platform.
Confirmit Express requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
Windows 7 or Windows 8 Desktop.
Web browser
Internet Explorer 11, Firefox (current and
previous 5 releases), Chrome (current
and previous 5 releases), Safari 4.
Internet Explorer 11, Firefox (latest), Safari 5, Chrome
(latest).
Web browsing
enhancement
(Internet
Explorer only)
Microsoft XML parser 3.0 SP3.
Microsoft XML parser 6.0
Office
components
Microsoft Office 2003 formats capable
office suite for opening exports:
Microsoft Office 2007, Microsoft Office 2010 or
Microsoft Office 2013.
 Microsoft Excel 2003-capable
spreadsheet editor required for
viewing Rapid Results exports.
2.3
Confirmit Reportal
Confirmit Reportal enables users to design and view reports so data collected from surveys can be analyzed. For a full
list of requirements for using Confirmit Reportal, consult the table below.
Confirmit Reportal requirements (design mode)
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
OS X.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11, Firefox (current and
previous 5 releases), Chrome (current and
previous 5 releases).
Internet Explorer 11, Firefox (latest), Chrome
(latest).
Web browsing
enhancement
(Internet
Explorer only)
Microsoft XML parser 3.0 SP3.
Microsoft XML parser 6.0
The Edge browser is not supported for Reportal, however users will be allowed to log on via Edge.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 5 of 16
Confirmit Reportal requirements (analyst mode)
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11, Firefox (current and
previous 5 releases), Chrome (current and
previous 5 releases).
Internet Explorer 11, Firefox (latest), Chrome
(latest).
Web browsing
enhancement
(Internet
Explorer only)
Microsoft XML parser 3.0 SP3.
Microsoft XML parser 6.0
Confirmit Reportal requirements (view mode)
Element
Operating
system
Web browser
Minimum
Recommended
Any operating system supported by the
operating system vendor.
Any operating system supported by the
operating system vendor.
 Internet Explorer 11
 Internet Explorer 11.
 Microsoft Edge
 Microsoft Edge (latest)*
 Opera 9
 Opera 9+.
 Firefox 10
 Firefox (latest).
 Safari 5.1
 Safari 5.1+.
 Chrome 26
 Chrome (latest).
Previous versions of Netscape, Internet
Explorer, Firefox, Safari, Chrome and Opera will
normally allow access to most functionality, but
Confirmit will not be supporting viewer related
issues with older browsers.

*)Report viewer components fully support the Edge browser for reports run on Confirmit SaaS environments, and for onpremise versions 19 or later. This support only applies to the newest versions of Confirmit reporting components, and not
to older versions which have been replaced by newer alternatives (e.g. Hitlist version 1 and Dundas chart components
are not supported).
Browser capability requirements
Element
Add-ons
Description
Browser embedded Macromedia Flash Player is required to display animated charts.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 6 of 16
Browser security settings (Internet Explorer only)
Element
Setting
Purpose / Effect
Download Signed ActiveX controls
Enable/
Prompt
Required to download and install Macromedia Flash Player
ActiveX component. Animated charts will not work if this setting is
disabled.
Run ActiveX controls and plugins
Enable
Animated charts in Confirmit Reportal rely on ActiveX controls that
are installed with Internet Explorer.
Script ActiveX controls marked as
safe for scripting.
Enable
Animated charts in Confirmit Reportal rely on ActiveX controls that
are installed with Internet Explorer.
Automatic prompting for file
downloads.
Enable
Only required if the Export Delivery Method is set to “Download” or
“User Defined” rather than Email.
Confirmit PowerPoint Add-in Requirements
Element
Minimum
Recommended
Operating
system
Microsoft Windows Vista SP2.
Microsoft Office
Version
Microsoft Office 2007 Service Pack 2, Microsoft Office 2010,
Microsoft Office 2013.
(as minimum).
Operating
System Extras
Microsoft .NET Framework 4.5.
(as minimum).
Operating
System Extras
Operating
system extras
Windows 7, Windows 8 or
Windows 10.
Microsoft Visual Studio 2010 Tools for Office.
(as minimum).
Microsoft Windows Installer 3.1
http://www.microsoft.com/downloads/details.aspx?FamilyID=8894
82fc-5f56-4a38-b838-de776fd4138c&DisplayLang=en
(as minimum).
Note: PowerPoint Add-in requirements (except OS and Microsoft Office version) will be installed automatically by the
PowerPoint Add-in setup application if not already installed.
2.4
Confirmit SmartHub
Confirmit SmartHub allows data sources of different types to be brought together for use in analysis and reporting.
Confirmit SmartHub requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
OS X.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11 (Windows only), Microsoft
Edge (current and previous 5 releases), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases).
Internet Explorer 11, Microsoft Edge (latest),
Chrome (latest), Firefox (latest).
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 7 of 16
2.5
Confirmit Discovery Analytics
Confirmit Discovery Analytics is an easy-to-use tool that helps analysts interact with, explore, and visualize data within
Confirmit SmartHub.
Confirmit Discovery Analytics requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
OS X.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11 (Windows only), Microsoft
Edge (current and previous 5 releases), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases).
Internet Explorer 11, Microsoft Edge (latest),
Chrome (latest), Firefox (latest).
2.6
Confirmit Instant Analytics
Confirmit Instant Analytics provides instant access to survey analytics with zero setup.
Confirmit Instant Analytics requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
OS X.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11 (Windows only), Microsoft
Edge (current and previous 5 releases), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases).
Internet Explorer 11, Microsoft Edge (latest),
Chrome (latest), Firefox (latest).
2.7
Confirmit Active Dashboards
Confirmit Active Dashboards provides actionable information relevant to each user’s role within the organization. Each
employee can receive a customized, interactive view of customer feedback data tailored to their specific roles and
responsibilities.
Confirmit Active Dashboards requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
OS X.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11 (Windows only), Microsoft
Edge (current and previous 5 releases), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases).
Internet Explorer 11, Microsoft Edge (latest),
Chrome (latest), Firefox (latest).
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 8 of 16
2.8
Confirmit Action Management
Confirmit Action Management initiates, coordinates, and accelerates organization-wide action responding to survey
feedback. Action Management may also be used to help coordinate the actions of team members on items unrelated to
survey response issues.
Confirmit Action Management requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
OS X.
Windows 7, Windows 8 Desktop or Windows
10.
Web browser
Internet Explorer 11 (Windows only), Microsoft
Edge (current and previous 5 releases), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases).
Internet Explorer 11, Microsoft Edge (latest),
Chrome (latest), Firefox (latest).
2.9
Hierarchy Management
The Confirmit Horizons Hierarchy Management functionality allows you to define and manage hierarchy definitions and
assign contacts to hierarchy units for hierarchies used in surveys and reporting in Confirmit Horizons.
Hierarchy Management Requirements
Minimum
Element
Recommended
Operating system
Windows Vista SP2.
OSX
Windows 7, Windows 8 Desktop or
Windows 10.
Web browser
Internet Explorer 11 (Windows only), Microsoft
Edge (current and previous 5 releases), Firefox
(current and previous 5 releases), Chrome
(current and previous 5 releases).
Internet Explorer 11, Microsoft Edge
(latest), Chrome (latest), Firefox (latest).
2.10
Confirmit Survey Engine (Respondents)
The Confirmit survey engine has been designed to comply with web standards so that surveys will function correctly in as
many browsers as possible. Note however that features such as client side scripts, media playing, the use of certain
cascading style sheet properties etc. that users add to surveys might alter the default requirements.
Confirmit Survey Engine requirements
Element
Minimum
Operating system
Any operating system supported by the operating system vendor.
Web browser
Any browser supporting HTML and CSS.
Advanced WI and
Dynamic Questions
features (optional), Inline
surveys
 Internet Explorer 8+
 Firefox 10+.
 Safari (Mac only) 5.1+.
 Chrome 26+.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 9 of 16
2.11
Confirmit Translator
The Confirmit Translator enables project managers to allow external users to translate their surveys directly in a graphics
user interface without the risk of changing the questionnaire layout. Translators can only access surveys that have been
prepared for translation by the project owner.
Confirmit Translator requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
Windows 7 or Windows 8
Desktop.
Web browser
Internet Explorer 11, Microsoft Edge (current and previous 5
releases), Firefox (current and previous 5 releases), Chrome
(current and previous 5 releases)
Internet Explorer 11, Microsoft
Edge (latest), Firefox (latest),
Chrome (latest).
2.12
Confirmit XML Web Services
The Confirmit XML Web Services provides an API for connecting external applications to Confirmit Horizons to allow
operations to be performed outside the GUI, such as the extraction of data into a company database.
Confirmit XML Web Services requirements (through APIs)
Element
Connectivity
2.13
Minimum
Access to the APIs is provided using SOAP, requiring a development
platform with SOAP capabilities.
Recommended
(Same as
minimum).
Confirmit CAPI
The Confirmit CAPI module adds offline interviewing capabilities to Confirmit Horizons through a downloadable
interviewer console. Confirmit Horizons provides an administrative interface for managing consoles and survey
deployment. Two versions are available; CAPI for Windows and CAPI for Android.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 10 of 16
2.13.1 CAPI for Windows
Confirmit CAPI for Windows requirements (interviewer console)
Element
Minimum
Recommended
Operating
system
Windows Vista SP2*.
Windows 7* or
Windows 8* or
Windows 10*.
Memory
1 Gb.
(Same as minimum).
CPU
2 GHz or greater.
(Same as minimum).
Web
Browser
Internet Explorer 11.
Internet Explorer 11.
Operating
system
extras
Microsoft .NET framework 2.0 –
(Same as minimum).
https://www.microsoft.com/en-gb/download/details.aspx?id=16614
Microsoft .NET Framework 4.5:
http://www.microsoft.com/en-US/download/details.aspx?id=30653
Operating
system
extras
Microsoft Web Services Enhancements (WSE) 3.0 runtime –
(Same as minimum).
http://www.microsoft.com/downloads/details.aspx?familyid=9E59C3FBE7BC-4D91-908E-411A8D329F3D&displaylang=en
Note: CAPI requirements (except OS and Web browser) will be installed automatically by the Confirmit CAPI setup
application if not already installed. Confirmit CAPI automatically installs .NET 2.0, .NET 4.5 and WSE 3.0 if not already
installed.
Note: Windows 8 RT edition is not supported.
*Dial-up connections have not been tested under 64-bit operating systems and are therefore not supported.
2.13.2 CAPI for Android
Confirmit CAPI for Android requirements (interviewer app)
Element
Operating
system
Minimum
Google™ Android 4.1 or greater.
Recommended
(Same as minimum).
2.13.3 CAPI for iOS
Confirmit CAPI for iOS requirements (interviewer app)
Element
Operating
system
Minimum
iOS 8.0 or greater.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Recommended
(Same as minimum).
Page 11 of 16
2.14
Confirmit Kiosk
The Confirmit Kiosk module adds offline interviewing capabilities to Confirmit Horizons through a downloadable
interviewer console. Confirmit Horizons provides an administrative interface for managing consoles and survey
deployment.
Confirmit CAPI requirements (interviewer console)
Element
Minimum
Recommended
Operating
system
Windows Vista SP2*.
Windows 7* or
Windows 8*,
Windows 10*.
Memory
1 Gb.
(Same as minimum).
CPU
2 GHz or greater.
(Same as minimum).
Web
Browser
Internet Explorer 11.
Internet Explorer 11.
Operating
system
extras
Microsoft .NET framework 2.0 –
(Same as minimum).
https://www.microsoft.com/en-gb/download/details.aspx?id=16614
Microsoft .NET Framework 4.5:
http://www.microsoft.com/en-US/download/details.aspx?id=30653
Operating
system
extras
Microsoft Web Services Enhancements (WSE) 3.0 runtime http://www.microsoft.com/downloads/details.aspx?familyid=9E59C3FBE7BC-4D91-908E-411A8D329F3D&displaylang=en
(Same as minimum).
Note: Kiosk requirements (except OS and Web browser) will be installed automatically by the Confirmit CAPI setup
application if not already installed. Confirmit CAPI automatically installs .NET 2.0, .NET 4.5 and WSE 3.0 if not already
installed.
Note: Windows 8 RT edition is not supported.
*Dial-up connections have not been tested under 64bit operating systems and are therefore not supported.
2.15
Confirmit CATI
The Confirmit CATI module adds support for online Computer Assisted Telephone Interviewing capabilities to Confirmit
Horizons through a downloadable interviewer console.
Confirmit CATI requirements (interviewer console)
Element
Minimum
Recommended
Operating
system
Windows Vista SP2.
Windows Vista,
Windows 7 or
Windows 8.
Memory
1 Gb.
(Same as minimum).
CPU
2 GHz or greater.
(Same as minimum).
Internet
Browser
Internet Explorer 9.
Internet Explorer 11.
Operating
system
extras
Microsoft Windows Installer 3.1
http://www.microsoft.com/downloads/details.aspx?FamilyID=889482fc-5f564a38-b838-de776fd4138c&DisplayLang=en
(Same as minimum).
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 12 of 16
Operating
system
extras
Microsoft .NET framework 4.0 (will also install .NET 2.0 and Windows
Installer 3.1 if required).
(Same as minimum).
http://www.microsoft.com/download/en/details.aspx?id=17851
Note: CATI requirements (except OS) will be installed automatically by the Confirmit CATI setup application if not already
installed. Confirmit CATI automatically installs Windows Installer 3.1 and .NET 4.0, if not already installed.
We recommend that users add Confirmit to “Trusted sites” in their browser’s security settings, and that the adjustments
to the security settings mentioned below should be done for trusted sites only:
Browser security settings
Element
Setting
Purpose / Effect
Display mixed content
Enable
Some surveys/survey layouts in HTTPS might use image sources
from a HTTP site and vice versa.
Submit non-encrypted form data
Enable
Will not be able to submit form data in Confirmit Horizons if this is
set to Disable.
Confirmit CATI Operational Requirements
Confirmit will not support call centre environments where interviewing PC’s do not meet our minimum requirements.
Furthermore, Confirmit will not support customers were interviewing PC’s are installed or configured with 3rd party
applications which run or interact with the host PC during shift times. Virus scanners, Windows Updates, and backup
software can be installed and enabled, but must be configured to run and self update out of operational hours. Other
applications such as spyware scanners and personal firewalls may impact your usage of Confirmit and therefore may
need to be disabled during operational hours also. Confirmit recommends that interviewer PC’s be locked down using
Group Policies to prevent unauthorised access to the Operating System, web sites and system configuration.
The Edge browser is not supported for CATI, however users will be allowed to log on via Edge.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 13 of 16
2.16
Confirmit Debug Station
Confirmit Debug Station is a downloadable application provided as part of the Confirmit license. The Debug Station is
aimed at users with programming skills who write advanced scripts as part of their surveys and who need to debug the
script code. Confirmit Debug Station must be installed on the user's PC. Confirmit Debug Station can be used to run
Confirmit surveys locally on the user's PC, attached to a .NET debugger, to debug script code in the survey (script
nodes, precode masks, question masks, conditions, validation code and piping).
Confirmit Debug Station requirements
Element
Minimum
Recommended
Operating
system
Windows Vista SP2*.
Windows 7* or
Windows 8* or
Windows 10*.
Memory
1 Gb.
(Same as minimum).
CPU
2 GHz or greater.
(Same as minimum).
Internet
Browser
Internet Explorer 11.
Internet Explorer 11.
Operating
system
extras
Microsoft .NET framework 2.0:
(Same as minimum).
https://www.microsoft.com/en-gb/download/details.aspx?id=16614
Microsoft .NET Framework 4.5:
http://www.microsoft.com/en-US/download/details.aspx?id=30653
Operating
system
extras
Web Services Enhancements (WSE) 3.0:
http://www.microsoft.com/downloads/details.aspx?familyid=9E59C3FBE7BC-4D91-908E-411A8D329F3D&displaylang=en
(Same as minimum).
Debug
application
A .NET 2.0 debug application is required, i.e.
No preference.
 Microsoft CLR Debugger (DbgCLR.exe) - distributed with ".NET
Framework Version 2.0 Software Development Kit" (SDK:
http://msdn2.microsoft.com/en-us/netframework/aa731542.aspx)
 Microsoft Visual Studio 2005/2008 (with built-in debugger).
Note: Confirmit Debug Station automatically installs .NET 2.0, .NET 4.5 and WSE 3.0 if not already installed.
Note: Windows 8 RT edition is not supported.
*Dial-up connections have not been tested under 64bit operating systems and are therefore not supported.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 14 of 16
2.17
Confirmit Data Central
Confirmit Data Central is a desktop application that helps streamline and optimize data processing functions. These
functions include data and metadata definition and manipulation, cleaning and recoding, reformatting, streaming,
weighting, and exporting. The generated data processing tasks can be either executed server site or locally depending
on the data processed.
Confirmit Data Central requirements
Element
Operating
system
Minimum
Recommended
Windows Vista SP2 (32 and 64-bit versions), Windows 7 (32 and 64-bit
versions).
If you wish to install Data Central on a Windows Vista machine, check for the
following:
Data Central requires that the user must have administrator privileges to
configure SQL Server access settings (and a number of other parameters). In
addition, as Windows Vista by default keeps the UAC feature turned on (a
feature introduced by Microsoft for security reasons), it may prevent some
installation and configuration steps from being completed. You can consider
doing the following (the procedure below applies to Windows Vista Business and
Ultimate editions only):

Use the Computer Management interface to find the Group Policy settings.
Next, find "User Account Control: Run all administrators in Admin Approval
Mode" parameter there and set it to Disabled.

Reboot the PC. On the next Windows Vista start, UAC feature will be
disabled.
Memory
512 Mb.
1 Gb.
CPU
1 GHz or greater.
(Same as
minimum).
Free Disk
space
30 MB minimum required.
Operating
system
extras
Microsoft .NET framework 3.5:
http://www.microsoft.com/downloads/details.aspx?FamilyID=AB99342F-5D1A413D-8319-81DA479AB0D7&displaylang=en
To run the Horizontal Merge operation, Microsoft SQL 2005 or 2008 is required
(any edition). A free version of Microsoft SQL 2005 Express edition can be
downloaded here:
http://www.microsoft.com/downloads/details.aspx?FamilyID=220549b5-0b074448-8848-dcc397514b41&DisplayLang=en
To import SPSS data (SAV, Quanvert, Dimension, Quancept, Surveycraft) the
Dimension Data Model of SPSS must be purchased and installed on your
machine. Contact SPSS for further information:
http://www.spss.com/data_model/.
Confirmit is not authorized to obtain a license for the SPSS Dimensions Data
Model, Confirmit is therefore in no position to test or reproduce issues related
thereto. We therefore expressly disclaim any and all warranties pertaining to
operations you may perform related to SPSS data, such as but not limited to
loading SPSS data to / from Confirmit, or running data through the SPSS Data
Model on Confirmit Data Central.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 15 of 16
2.18
Confirmit TCI
Confirmit TCI (Telephony Computer Interface) is a powerful telephony add-on to Confirmit CATI. The system fully
automates the dialing of telephone numbers on behalf of the interviewers, dramatically increasing call centre productivity.
Furthermore, features such as real time monitoring, full call recording and verbatim recording significantly increase call
centre quality. If your company plans to utilize a Dialer as part of your CATI activities via the Confirmit Software, a
number of additional system requirements will apply. Full system requirements are found in the Confirmit Local Dialer
System Requirements document, available from http://www.confirmit.com/legals/legal.aspx.
2.19
Confirmit Local Dialer Web Service
Confirmit Local Dialer Web Service is the component responsible for communicating between Confirmit CATI and a
supported local dialer. If your company plans to utilize a Dialer as part of your CATI activities via the Confirmit Software,
a number of additional system requirements will apply. Full system requirements are to be found in the Confirmit Local
Dialer System Requirements document, available from http://www.confirmit.com/legals/legal.aspx.
CONFIRMIT Confidential. Copyright © 2016 CONFIRMIT. All Rights Reserved
Confirmit Horizons User System Requirements (Revised: 2016-06-30)
Page 16 of 16

Similar documents

×

Report this document